Besuchen Sie auch unsere anderen Web-Sites:
www.meconet.de | shop.meconet.de | forum.meconet.de

transparentes bridging zwischen zwei Netzwerken mit WDS

(Stand: RouterOS ab Version 2.9)

Wie schon im Einführungs-Artikel zu der Thematik aufgeführt, ist WDS die einzige Technik, um zwei entfernte Netzwerke transparent über einen WLAN-Link zu bridgen, ohne weitere Tunnel (EoIP oder MPLS/VPLS) oder anderweitige Tricks (MAC NAT) zu verwenden. Somit ist die WDS-Konfiguration sicherlich die sinnvollste Art für diesen Einsatzzweck.

Bitte beachten Sie, dass WDS nur an WLAN-Interfaces gebunden werden kann, somit also nur zwischen zwei WLAN-Systemen verwendet werden kann, die direkt miteinander verbunden sind. Es ist mit WDS nicht möglich direkt über mehrere Hops oder auch über beliebige IP-Verbindungen eine transparente Layer 2 Verbindung zu realisieren.

Bei WDS sind einige Einschränkungen zu machen, wenn das System in ETSI regulierten Umgebungen mit 5GHz betrieben werden soll. Nicht alle Konfigurationsmöglichkeiten, die das System bietet, können hier eingesetzt werden, da - je nach Art der Konfiguration - z. B. keine automatische Kanalauswahl funktioniert. Diese ist aber in diesen Ländern bei der Verwendung von 5GHz vorgeschrieben (DFS). Selbstverständlich hält sich die folgende Konfiguration entsprechend an die regulatorischen Vorgaben.

Anzumerken ist hier noch, dass die Verwendung von WDS in Punkt-zu-MehrPunkt (PtMP) Installationen 50% der verfügbaren Bandbreite kostet. Diese Einschränkung ist bei Punkt-zu-Punkt (PtP) Installationen nicht gegeben. Der Netto-Datendurchsatz einer PtP-Strecke mit WDS ist höher als bei der Verwendung von EoIP.

Das Szenario

Die Konfiguration

Systemnamen vergeben

für System 1

/system identity set name=SYS-1

für System 2

/system identity set name=SYS-2

Wireless konfigurieren

WLAN- & WDS-AP auf System 1

Zunächst lassen Sie sich die verfügbaren WLAN-Interfaces Ihres Systems anzeigen

/interface wireless print

Ergibt eine Ausgabe analog zu dieser

  [admin@SYS-1] > interface wireless print  
  Flags: X - disabled, R - running 
  0 X  name="wlan1" mtu=1500 mac-address=00:0C:42:23:28:62 arp=enabled 
      interface-type=Atheros AR5413 mode=station ssid="MikroTik" 
      frequency=5180 band=5ghz scan-list=default antenna-mode=ant-a 
      wds-mode=disabled wds-default-bridge=none wds-ignore-ssid=no 
      default-authentication=yes default-forwarding=yes default-ap-tx-limit=0 
      default-client-tx-limit=0 hide-ssid=no security-profile=default 
      compression=no 

Nun kann das vorhandene und noch deaktivierte (Flag = X) WLAN-Interface mit der Nummer 0 oder über seinen Namen wlan1 konfiguriert werden. In diesem Beispiel werden nur die notwendigsten Parameter für den Einsatz in Deutschland konfiguriert 1).

/interface wireless set wlan1 mode=bridge band=5ghz frequency=5500 ssid=MeineSSID frequency-mode=regulatory-domain country=germany scan-list=5470-5720

Als nächstes wird der WDS-AP angelegt und seinem Master-Interface (hier wlan1) zugeordnet. Damit sich die Gegenseite (System 2) auch per WDS mit diesem WDS-AP verbinden kann, muss hierbei die MAC-Adresse des entsprechenden WLAN-Interfaces der Gegenseite (hier auch wlan1 auf System 2) mit eingetragen werden. In diesem Beispiel hat wlan1 auf System 2 die MAC-Adresse 00:0C:42:18:75:4D

/interface wireless wds add name=wds1 master-interface=wlan1 wds-address=00:0C:42:18:75:4D

Jetzt muss noch WDS an sich noch aktiviert werden, für diesen Einsatzzweck verwenden wir statisches WDS

/interface wireless set wlan1 wds-mode=static 

Jetzt müssen das WLAN- und das WDS-Interface nur noch aktiviert werden

/interface wireless set wlan1 disabled=no
/interface wireless wds set wds1 disabled=no

WDS-Client auf System 2

Zunächst lassen Sie sich die verfügbaren WLAN-Interfaces Ihres Systems anzeigen

/interface wireless print

Ergibt eine Ausgabe analog zu dieser

  [admin@SYS-2] > interface wireless print 
  Flags: X - disabled, R - running 
  0 X  name="wlan1" mtu=1500 mac-address=00:0C:42:18:75:4D arp=enabled 
      interface-type=Atheros AR5413 mode=station ssid="LAB-AP2" 
      frequency=5180 band=5ghz scan-list=default antenna-mode=ant-a 
      wds-mode=disabled wds-default-bridge=none wds-ignore-ssid=no 
      default-authentication=yes default-forwarding=yes default-ap-tx-limit=0 
      default-client-tx-limit=0 hide-ssid=no security-profile=default 
      compression=no 

Nun kann auch dieses Interface konfiguriert werden. Auch hier machen wir exemplarisch nur die notwendigsten Konfigurationen für den Einsatz in Deutschland, zunächst ohne DFS.

/interface wireless set wlan1 mode=station-wds band=5ghz ssid=MeineSSID frequency-mode=regulatory-domain country=germany scan-list=5470-5720

Jetzt muss das WLAN-Interface nur noch aktiviert werden

/interface wireless set wlan1 disabled=no

Nun kann leicht überprüft werden, ob sich der WLAN-Client mit dem WLAN-AP assoziiert hat

/interface wireless monitor wlan1

ergibt eine Ausgabe analog zu dieser

  [admin@SYS-2] > interface wireless monitor wlan1 
                 status: connected-to-ess
                   band: 5ghz
              frequency: 5500MHz
                tx-rate: "6Mbps"
                rx-rate: "6Mbps"
                   ssid: "MeineSSID"
                  bssid: 00:0C:42:23:28:62
             radio-name: "000C42232862"
        signal-strength: -55dBm
     tx-signal-strength: -53dBm
            noise-floor: -96dBm
        signal-to-noise: 41dB
                 tx-ccq: 59%
                 rx-ccq: 58%
           p-throughput: 5535
         overall-tx-ccq: 59%
  authenticated-clients: 1
    current-ack-timeout: 28
               wds-link: yes
                nstreme: no
           framing-mode: none
       routeros-version: "4.2"
    802.1x-port-enabled: yes

Hier sehen Sie, dass der Client auf dem AP eingebucht ist status: connected-to-ess sowie alle wichtigen und notwendigen Parameter für die WLAN-Verbindung und dass es sich um einen WDS-Link handelt wds-link: yes.

Bridges konfigurieren

Bridge-Konfiguration auf System 1

Zunächst lassen Sie sich die verfügbaren Bridge-Interfaces Ihres Systems anzeigen

/interface bridge print

Auf einem frischen System sollten Sie keine bestehenden Bridge-Interfaces sehen

  [admin@SYS-1] > interface bridge print 
  Flags: X - disabled, R - running 

Somit können wir jetzt die notwendige Bridge anlegen

/interface bridge add name=bridge1

Und dann ein Ethernet-Interface (hier ether1) und das oben konfigurierte WDS-Interface (hier wds1) als Ports der Bridge hinzufügen

/interface bridge port add bridge=bridge1 interface=ether1
/interface bridge port add bridge=bridge1 interface=wds1

Bridge-Konfiguration auf System 2

Bevor wir diese konfigurieren, sollten Sie das Ethernet-Kabel aus System 2 entfernen, da Sie ansonsten einen Ethernet-Loop in Ihrem Netzwerk konfigurieren. Da das wireless Client Interface ja auf dem WDS-AP eingebucht ist und dieser schon zwischen Ethernet und dem WDS-Interface bridget, ist es ja auch kein Problem über den wireless Link per Winbox (Layer 2) auf das System 2 zuzugreifen.

Hierfür ist allerdings Vorraussetzung, dass das Neighbor Discovery auf dem entsprechendem WLAN-Interface läuft. Dies prüfen Sie mit

/ip neighbor discovery print 

Sollten Sie folgende Ausgabe bekommen

  [admin@SYS-2] > ip neighbor discovery print 
  # NAME                                                                DISCOVER
  0 ether1                                                              yes     
  1 ether2                                                              yes     
  2 ether3                                                              yes     
  3 wlan1                                                               no

Führen Sie noch folgenden Befehl aus, bevor Sie das Ethernetkabel trennen

/ip neighbor discovery set wlan1 discover=yes

Wenn Sie die Konfiguration per serieller Console machen stellt sich diese Frage eh nicht.

Zunächst lassen Sie sich die verfügbaren Bridge-Interfaces Ihres Systems anzeigen

/interface bridge print

Auch hier sollten Sie keine vorhandene Bridge sehen, sofern es sich um ein frisch installiertes System handelt.

  [admin@SYS-1] > interface bridge print 
  Flags: X - disabled, R - running 

Somit können wir jetzt auch hier die notwendige Bridge anlegen

/interface bridge add name=bridge1 

Und auch hier die notwendigen Interfaces hinzufügen

/interface bridge port add bridge=bridge1 interface=ether1
/interface bridge port add bridge=bridge1 interface=wlan1

Testen der Bridge-Konfiguration

Mit dem Befehl

/interface bridge host print

können Sie sich auf beiden Systemen anzeigen lassen, welche Hosts das jeweilige System hinter welchem Interface sieht

  [admin@SYS-1] > interface bridge host print
  Flags: L - local, E - external-fdb 
    BRIDGE           MAC-ADDRESS       ON-INTERFACE          AGE                 
    bridge1          00:00:5E:00:01:0A ether1                1s                  
    bridge1          00:03:FF:36:2B:AF ether1                1m49s               
  L bridge1          00:0C:42:21:8C:D5 ether1                0s                  
  L bridge1          00:0C:42:23:28:62 wds1                  0s                  

System 1 sieht z. B. zwei Hosts im lokalen, kabelgebundenen Ethernet hinter ether1, die beiden mit L gekennzeichneten Einträge in der Liste sind die MAC-Adressen des eigenen Interfaces ether1 und wds1.

  [admin@SYS-2] > interface bridge host print
  Flags: L - local, E - external-fdb 
    BRIDGE           MAC-ADDRESS       ON-INTERFACE          AGE                 
    bridge1          00:00:5E:00:01:0A wlan1                 0s                  
    bridge1          00:03:FF:36:2B:AF wlan1                 1m44s               
  L bridge1          00:0C:42:18:75:4D wlan1                 0s                  

System 2 sieht die selben MAC-Adressen (00:00:5E:00:01:0A und 00:03:FF:36:2B:AF) wie auch System 1, korrekterweise allerdings hinter dem Interface wlan1, also hinter dem Interface das die Layer 2 Verbindung zu System 1 hat.

Die Bridge funktioniert also.

IP-Konfiguration

Auch wenn eine reine Bridge zum Betrieb keine IP-Adressen benötigt, ist es eventuell sinnvoll den Systemen jeweile eine IP-Adresse für das Management zu geben. Hierbei ist zu beachten, dass die IP-Adressen an die jeweilige Bridge (logisches Interface) gebunden wird, nicht an ein physikalisches Interface welches Mitglied einer Bridge ist (ether1, wds1 oder wlan1). Dies funktioniert zwar, kann aber unter Umständen zu Fehlern führen.

IP-Konfiguration für System 1

/ip address add address=192.168.1.1/24 interface=bridge1

IP-Konfiguration für System 2

/ip address add address=192.168.1.2/24 interface=bridge1

Testen der IP-Konfiguration

Mit dem Befehl

/ip address print

erhalten Sie immer eine Liste aller im System vergebenen IP-Adressen und an welches Interface diese gebunden sind.

  [admin@SYS-1] > ip address print 
  Flags: X - disabled, I - invalid, D - dynamic 
  #   ADDRESS            NETWORK         BROADCAST       INTERFACE              
  0   192.168.1.1/24     192.168.1.0     192.168.1.255   bridge1    

Oder Sie verwenden den Ping-Befehl von System 1 zu System 2 (oder andersherum)

  [admin@SYS-2] > ping 192.168.1.1
  192.168.1.1 64 byte ping: ttl=64 time=7 ms
  192.168.1.1 64 byte ping: ttl=64 time=10 ms
  192.168.1.1 64 byte ping: ttl=64 time=9 ms
  192.168.1.1 64 byte ping: ttl=64 time=10 ms
  192.168.1.1 64 byte ping: ttl=64 time=9 ms
  192.168.1.1 64 byte ping: ttl=64 time=9 ms
  192.168.1.1 64 byte ping: ttl=64 time=9 ms
  192.168.1.1 64 byte ping: ttl=64 time=9 ms
  192.168.1.1 64 byte ping: ttl=64 time=10 ms
  9 packets transmitted, 9 packets received, 0% packet loss
  round-trip min/avg/max = 7/9.1/10 ms

RouterOS führt in der Konsole immer einen Dauerping aus, diesen können Sie durch gleichzeitiges drücken der Tasten STRG und c jederzeit abbrechen.

Test der Konfiguration

Die Konfiguration können Sie nun ganz einfach testen. Schließen Sie einfach z. B. einen PC hinter System 2 an. Wenn in Ihrem Netz hinter System 1 ein DHCP-Server steht, können Sie diesen Client sogar einfach auf DHCP stellen. Er sollte seine IP-Konfiguration bekommen. Wenn Sie keinen DHCP-Server im Einsatz haben, machen Sie die entsprechende IP-Konfiguration auf dem Client per Hand.

In beiden Fällen sollten Sie mit dem Client auf Systeme im Netzwerk hinter System 1 zugreifen können.

Download der Konfigurations-Dateien

Hier können Sie für System 1 und System 2 aus diesem Beispiel die komplette Konfiguration als Datei im ASCII-Format herunterladen. Diese Konfigurations-Dateien können direkt auf einen Router gespielt werden. Hier finden Sie eine detaillierte Anleitung, wie Sie diese ASCII-Dateien auf ein RouterOS-System per serieller Verbindung aufspielen können.

* miniconfig_transbridge_wds_system1.txt

1) Ohne DFS, da das System sonst nach jedem Neustart des WLAN-Interfaces zunächst 60 Sek. nach Radar-Mustern scannt, bitte denken Sie unbedingt daran am Ende der Konfiguration DFS zu aktivieren, wenn Sie 802.11a verwenden!
mikrotik/ros/transparentes_bridging_wds.txt · Zuletzt geändert: 23.11.2009 21:14 (Externe Bearbeitung)
www.meconet.de | shop.meconet.de | forum.meconet.de